Selasa, 04 Mei 2010

Time Stamping Service (TSS)

argghh,,,temen2 semuanya..lagi searching2 di database tugas alias laptop, ada materi bagus untuk rekan rekan sekalian.. bingung kan cara untuk menghindari choosen plaintext atack tu gimana,,nah ini salah satu solusi yang ditawarkan..Time stamping Service.
special thanks untuk abang2 saya tingkat IV TK (bang gigih, bang andri hamzah, mba rike)..tugas protokol kriptografinya kebetulan banget jadi referensi untuk tugas saya sekarang,,hhe.



Time Stamping Service
Stuart Haber dan W. Scott Stornetta di Bacellore memunculkan sebuah ide tentang protokol digital timestamping dengan karakteristik sebagai berikut :
• Data tersebut harus telah di timestamp, tanpa memperhatikan medium fisik dimana dokumen tersebut berada.
• Dokumen memungkinkan untuk diubah ke bentuk single bit tanpa terlihat.
• Dokumen tidak memungkinkan untuk di timestamp dengan tanggal dan waktu yang tidak bisa dimajukan atau diundurkan dari waktu yang sebenarnya.

Encryption Control Protocol (ECP)




Tugas Kriptografi Jaringan
Encryption Control Protocol (ECP)
Oleh :
Indra Adi Putra (0706100725)
Ninik Ratna Dewi (0706100737)
R. Ahmad Imanullah Zakaria (0706100)
Rio Yunia Pratama (0706100737)


ECP (Encryption Control Protocol)
ECP bertanggung jawab untuk mengkonfigurasi dan mengaktifkan algoritma enkripsi data pada kedua ujung akhir point to poin link. ECP menggunakanmekanisme pergantian paket yang sama seperti Link Control Protocol (ECP).
Paket-paket ECP tidak boleh ditukar hingga PPP telah mencapai fase Network Layer Protocol. Sebelum fase ini dicapai maka paket ECP harus diterima.
ECP sama dengan LCP dengan beberapa perbedaaan:



3.1 Frame modification
Paketnya biasanya terdiri dari beberapa modifikasi untuk format basic frame, di mana mampu untuk mengatasi fase Link-Establishment.

3.2 Data link Layer Protocol Field
Seharusnya tiap paket ECP harus merupakan bagian dari PPP, contohnya adalah tipe hex 8053 (ECP).

3.3 Code field
ECP menggunakan kode (desimal) 1-7 (configure request, configure ack, configure nak, configure reject, terminate request, terminate ack, code reject), dan juga biasanya menggunakan kode 14 (reset request) dan kode 15 (reset ack). Kode lainnya yang tidak digunakan akan berada di Code Reject.

3.4 Negotiation
Paket ECP tidak akan bisa dipertukarkan hingga PPP mencapai fase network layer protocol. Implememtasinya harus dipersiapkan terlebih dahulu untuk menunggu otentikasi dan link quality determination agar prosesnya dapat terselesaikan sebelum waktu untuk menunggu Configure-Ack dan respon lainnya habis. Pada impelentasi, tidak harus mentransmisikan data hingga proses Negotiation ECP telah komplit. Jika ECP negotiation tidak complete, maka link akan rusak.

3.5 Configuration Option Types
ECP mempunyai perbedaaan pada Configuration Option
3.6 Sending Encryption Datagrams
Sebelum paket yang terenkripsi dihubungkan, PPP harus mencapai pada fase Network-Layer Protocol, dan ECP harus mencapai fase open state. Sebuah paket enkripsi merupakan bagian dari PPP dimana protocol PPP tersebut merupakan tipe hex 0053 (datagram terenkripsi).
Ketika menggunakan multiple link PPP menjadi single destination, ada 2 metode untuk data encryption:
a. Metode pertama adalah untuk mengenkripsi data prior untuk dikirimkan melalui multiple link. Dalam hal ini, Protocol PPP harus keluarga dari tipe hex 0053.
b. Metode yang kedua memperlakukan tiap link sebagai koneksi yang terpisah, bisa juga atau bisa tidak menggunakan enkripsi. Pada link yang menggunakan Negotiated Encryption, protocol PPP harus tipe hex 0055 (Indivividual link encypted datagram)
Panjang maksimum dari sebuah paket terenkripsi yang diteransmisikan melalui PPP link sama panjangnya dengan panjang maksimum dari information field pada paket PPP yang terenkapsulasi. Jika algoritma enkripsinya sepertinya terlihat akan meningkat ukurannya pada pesan, multy link sebaiknya diikutkan juga pada frame, algoritma enkripsi tersebut harus menjelaskan cara dari determinasi jika datanya reliable, atau harus memenuhi penggunaan dari transport reliably seperti LABP.
Kompresi biasanya digunakan pada Protocol Compresi Control. Untuk menjaminnya, plaintext harus dikompresi terlebih dahulu, lalu dilanjutkan proses enkripsi.
3.7 Additional Packet (Paket tambahan)
ECP terdiri dari kode Reset Request dan Reset Ack yang digunakan untuk menyediakan mekanisme untuk mengetahui adanya kegagalan pada proses dekripsi di salah satu arah pada link yang terdekripsi tanpa harus mengetahui lalu lintas arah yang lain. Di beberapa algoritma enkripsi tidak harus menggunakan mekanisme ini.
Masing – masing algoritma dibutuhkan penjelasan mekanisme untuk menjelaskan bagaimana mendeteksi sebuah kegagalan dalam proses dekripsi. Initial detection pada sebuah kegagalan proses dekripsi, implementasinya pada sebuah ECP harus mentransmisikan paket ECP dengan kode field yang diset sebagai 14 (Reset Request).
Pada waktu Reset Request dikirim, ada paket enkripsi yang diterima namun ada juga yang ditolak. Selama Reset Request tersebut dikirim dengan pengenal yang sama, hingga valid Reset Ack diterima
Ringkasan dari Reset Request dan Reset Act seperti bagan dibawah ini. Field harus ditransmisikan dari kiri ke kanan
0 1 2 3
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| Code | Identifier | Length |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| Data ...
+-+-+-+-+

Code
Untuk Reset Request
Untuk Reset Act
Identifier
Selama transmisi, identifier harus diubah ketika isi dari data field berubah
Data
Data field adalah NOL atau nilai oktedan terdiri dari data yang tidak diinterprestasikan untuk penggunaan oleh sender.
7. Karakteristik Encryption Control Protocol
1. Mendefinisikan sebuah metode untuk bernegosiasi data enkripsi PPP link
2. Bertanggung jawab untuk mengkonfigurasi algoritma enkripsi dan memungkinkan data pada kedua ujung point to point link.
3. ECP menggunakan mekanisme pertukaran paket sama dengan Link Control Protocol (LCP), namun Paket teesebut tidak dapat ditukar sampai PPP mencapai fase Network-Layer Protocol
4. ECP Hampir sama seperti LCP, namun yang membedakan adalah
- Bingkai Modifikasi
Paket dapat memanfaatkan setiap modifikasi pada kerangka dasar format yang telah dinegosiasikan selama Pendirian Link tahap.
- Data Link Layer Protokol Field.
Tepat satu paket ECP dirumuskan dalam PPP Informasi field, di mana bidang Protokol PPP menunjukkan jenis hex 8053 (Enkripsi Control Protocol).
- Kode bidang (Code Field)
- Perundingan
- Konfigurasi Opsi Jenis
5. Sebelum paket-paket dienkripsi oleh ECP, PPP sebelumnya harus mencapai Network-Layer Protocol fase
6. ECP memiliki reset request dan Reset Ack Codes dalam rangka memberikan mekanisme untuk menunjukkan kegagalan dekripsi dalam satu arah dari link yang didekripsi tanpa mempengaruhi arah (direction )yang lain, skema enkripsi yang lain tidak membutuhkan mekanisme ini.
7. Pada ECP terdapat configuration options yang menyediakan cara untuk menegosiasikan penggunaan algoritma enkripsi publik didefinisikan.
8. ECP menggunakan format yang sama untuk configuration options seperti yang ada pada LCP, dengan seperangkat Options yang terpisah.
Configuration Options dalam protokol ini, menunjukkan bahwa algoritma penerima bersedia atau dapat digunakan untuk mendekripsi data yang dikirim oleh pengirim. Sistem dapat menawarkan untuk menerima beberapa algoritma, dan menentukan Algoritma yang akan digunakan.
9. ECP menggunakan teknik pilihan negosiasi LCP untuk menegosiasikan enkripsi algoritma yang digunakan.
8. Implementasi Encryption Control Protocol :
Implementasi pada ECP untuk mendekripsi menggunakan enkripsi tertentu dari suatu algoritma (atau salah satu dari serangkaian algoritma) sebagai pilihan ECP untuk Mengkonfigurasikan permintaan, panggilan akhir ini dari seorang Decrypter atau Encrypter.
Decrypter mendukung lebih dari satu algoritma enkripsi dan dapat mengirim permintaan dan mengkonfigurasikannya dengan baik, salah satunya dengan :
- Memberikan daftar dengan nomor pilihan, dengan enkripsi yang paling disukai dengan algoritma kedatangan pertama
- Atau hanya mungkin menawarkan pilihan (yang tidak sudah Ditolak) pilihan.
Jika Encrypter menolak semua menawarkan pilihan ECP dan decrypter tidak memiliki lebih lanjut dalam menawarkan pilihannya maka Configuration request ditolak.

Referensi
Rand, D., "PPP Transmisi Handal", RFC 1663, Novell, Juli 1994.
Rand, D., "The kompresi PPP Control Protocol (PKC)", RFC 1962, Novell, Juni 1996.
Reynolds, J., dan Postel, J.; "DITEMPATKAN ANGKA", STD 2, RFC 1700, USC / Information Sciences Institute, Oktober 1994.
RFC 1968- The PPP Encryption Control Protocol (ECP)
Simpson, W. 1994. The Point-to-Point Protocol (PPP) RFC 1661
Simpson, W., Editor; "Protokol Point-to-Point (PPP)", STD 51, RFC 1661, Juli 1994.
Sklower, K., dan G. Meyer, "PPP The Protokol Enkripsi DES (DESE) ", RFC Juni 1969, University of California, Berkeley, 1996.
Sklower, K., Lloyd, B., McGregor, dan G. dan D. Carr, "The PPP Multilink Protocol (MP) ", RFC c 1717, University of California, Berkeley, November 1994.
The PPP Encryption Control Protocol (ECP) – draft-ietf-pppext-encryption-00.txt
Tunnissen, Jacko. 1996. RFC 1968
Wang, C David. 2009. EE 6364 Advanced Data Networks

Belajar Tentang Point to Point Protocol

untuk tugas sebelumnya, kami sekelompok mendapat tugas tentang kriptografi jaringan. memang, tugas itu gabungan dari TK dan RB, Ninik Ratna Dewi, Indra Adi putra, Rio Yunia, dan R.Imanullah.
intinya kami nyari tahu tentang apa itu PPP dan ECP. untuk postingan sekarang, coba dijelaskan tentang PPP, aka Point to point Protocol.


Point-to-Point Protocol (PPP) adalah protokol yang digunakan untuk enkapsulasi transportasi IP di link point-to-point. PPP memiliki standar pembagian tugas dan manajemen IP address, sinkronisasi, multiplek protokol jaringan, konfigurasi link, link untuk pengujian kualitas, deteksi kesalahan, dan pilihan kemampuan negosiasi seperti negosiasi network-layer address dan negosiasi kompresi data. PPP didesain untuk transport multi protokol antara dua pihak dengan menggunakan link sederhana. Link yang digunakan beroperasi dua arah (Tunnissen, RFC 1968).
Sesuai dengan yang ditulis Simpson dalam RFC 1661 tentang The Point-to-Point Protocol (PPP), PPP terdiri dari tiga komponen yakni method untuk enkapsulasi datagram multi protokol, Link Control Protocol (LCP) untuk membangkitkan, mengkonfiguasi, dan mengetes koneksi data link, dan Network Control Protocol (NCP)yang digunakan untuk mengkonfigurasi dan membangkitkan protokol network layer yang berbeda.




Sebelum dua pihak dapat mengirim paket data, masing-masing link PPP harus mengirim paket LCP untuk mengkonfigurasi dan mengetes data link. Saat link terbentuk, pihak yang berkomunikasi akan diotentikasi, lalu PPP mengirim paket NCP untuk memilih protocol network layer. Setelah itu, datagram dapat dikirim melalui link.

Encryption Control Protocol (ECP) adalah salah satu protocol dalam PPP yang dapat digunakan untuk menyediakan layanan confidentiality. Untuk penjelasan selanjutnya akan dibahas pada bagian berikutnya(cont)

Jumat, 30 April 2010

percayalah,,,

akhirnya,,saking sudah lamanya saya g curhat tentang hidup ini,,kali ini saya posting tentang fenomena cinta...
tulisan ini saya ambil dari notes nya temen sekelas saya,,agria rhamdhan namanya,,,katanya sih dia ngumpulin idenya dari 3 harian yang lalu,,,wkwkkk
langsung aja di baca ya gann^^



Agi Ramdan: buat 2 temen gw yang lagi "BERANTEM"


Kadangkala orang yang paling mencintaimu adalah orang yang tak pernah menyatakan cintanya kepadamu karena orang itu takut kau akan berpaling dan menjauhinya. Dan bila pada suatu saat dia pergi dan hilang dari pandanganmu…. kau akan menyadari bahwa dia adalah cinta yang tidak pernah kau sadari….

Janganlah engkau mencintai seseorang terlalu berlebihan, karena pada suatu saat orang tersebut akan menjadi orang yang paling engkau benci. Janganlah engkau membenci seseorang terlalu berlebihan, karena pada suatu saat orang tersebut akan menjadi orang yang paling engkau cintai.




Ketika cinta memanggilmu maka dekatilah dia walau jalannya terjal berliku, jika cinta memelukmu maka dekaplah ia walau pedang di sela-sela sayapnya melukaimu.

Jika cinta tidak dapat mengembalikan engkau kepadaku dalam kehidupan ini, pastilah cinta akan menyatukan kita dalam kehidupan yang akan datang…..

Jika kita mencintai seseorang, kita akan sentiasa mendoakannya walaupun dia tidak berada disisi kita.

Tuhan memberi kita 2 kaki untuk berjalan, 2 tangan untuk memegang, 2 telinga untuk mendengar dan 2 mata untuk melihat. Tetapi mengapa Tuhan hanya menganugerahkan sekeping hati pada kita? Karena Tuhan telah memberikan sekeping hati pada seseorang untuk kita mencarinya. Itulah namanya Cinta… Jangan sesekali mengucapkan selamat tinggal jika kamu masih mau mencoba. Jangan sesekali menyerah jika kamu masih merasa sanggup. Jangan sesekali mengatakan kamu tidak mencintainya lagi jika kamu masih tidak dapat melupakannya.

Cinta datang kepada orang yang masih mempunyai harapan walaupun mereka telah dikecewakan. Kepada mereka yang masih percaya, walaupun mereka telah dikhianati. Kepada mereka yang masih ingin mencintai, walaupun mereka telah disakiti sebelumnya dan kepada mereka yang mempunyai keberanian dan keyakinan untuk membangunkan kembali kepercayaan. Jangan simpan kata-kata cinta kepada orang yang tersayang sampai dia meninggal dunia, yang akhirnya kamu terpaksa mencatat kata-kata cintamu itu pada makamnya. Sebaliknya ucapkan kata-kata cinta yang tersimpan dibenakmu itu sekarang selagi sempat.

Siapakah seseorang yang mencintaimu? Yaitu:

1. Orang yang mencintai kamu tidak pernah mampu memberikan alasan kenapa dia mencintai kamu. Yang dia tahu di hati dan matanya hanya ada kamu satu-satunya.

2. Orang yang mencintai kamu selalu menerima kamu apa adanya, di hati dan matanya kamu selalu yang tercantik walaupun mungkin kamu merasa berat badan kamu sudah bertambah.

3. Orang yang mencintai kamu selalu ingin tahu tentang apa saja yang kamu lalui sepanjang hari ini, dia ingin tahu kegiatan kamu.

4. Orang yang mencintai kamu akan mengirimkan SMS seperti ‘Selamat Pagi‘, ‘Selamat Tidur‘, ‘take care’, dan lain-lain, walaupun kamu tidak membalas SMS-nya, karena dengan kiriman SMS itu dia menyatakan cintanya dalam cara yang berbeda, bukan “aku CINTA padamu”, tapi berselindung ayat selain kata cinta itu.

5. Jika kamu merayakan hari ulang tahun dan kamu tidak mengundangnya, maka setidak-tidaknya dia akan menelepon untuk mengucapkan selamat atau mengirim SMS.

6. Orang yang mencintai kamu akan selalu mengingat setiap kejadian yang dia lalui bersama kamu, bahkan mungkin kejadian yang kamu sendiri sudah melupakannya, karena saat itu adalah sesuatu yang berharga untuknya. Dan saat itu, matanya pasti berkaca, karena saat bersamamu itu tidak bisa selalu berulang.

7. Orang yang mencintai kamu selalu mengingat setiap kata-kata yang kamu ucapkan, bahkan mungkin kata-kata yang kamu sendiri lupa pernah mengungkapkannya. Karena dia menempatkan kata-katamu di hatinya. Berapa banyak kata-kata penuh harapan yang kau ucapkan padanya, dan akhirnya kau musnahkan? Pasti kau lupa, tetapi bukan bagi orang yang mencintai kamu.

8. Orang yang mencintai kamu akan belajar menggemari lagu-lagu kegemaran kamu, bahkan mungkin meminjam CD milik kamu, karena dia ingin tahu apa kegemaran kamu - kesukaan kamu kesukaannya juga - walaupun sukar meminati kesukaan kamu, tapi akhirnya dia bisa.

9. Kalau kali terakhir kalian bertemu, kamu mungkin sedang flu, atau batuk-batuk, dia akan sentiasa mengirim SMS atau menelepon untuk bertanya keadaan kamu - karena dia bimbangkan tentang kamu, peduli tentang kamu.

10. Jika kamu mengatakan akan menghadapi ujian, dia akan menanyakan kapan ujian itu berlangsung, dan pada saat harinya tiba dia akan mengirimkan SMS untuk memberi semangat kepada kamu.

11. Orang yang mencintai kamu akan memberikan suatu barang miliknya yang mungkin buat kamu itu adalah sesuatu yang biasa, tetapi baginya barang itu sangat istimewa.

12. Orang yang mencintai kamu akan terdiam sesaat, ketika sedang berbicara di telepon dengan kamu, sehingga kamu menjadi bingung. Sebenarnya saat itu dia merasa sangat gugup karena kamu telah menyejukkan hatinya.

13. Orang yang mencintai kamu selalu ingin berada di dekat kamu dan ingin menghabiskan hari-harinya hanya dengan kamu.

14. Jika suatu saat kamu harus pindah ke daerah lain, dia akan sentiasa memberikan nasihat agar kamu waspada dengan lingkungan sekitar yang mungkin membawa pengaruh buruk kepada kamu. Dan jauh dihatinya dia benar-benartakut kehilangan kamu.. ‘jauh dimata, jauh dihati‘

15. Orang yang mencintai kamu bertindak lebih seperti saudara daripada seperti seorang kekasih.

16. Orang yang mencintai kamu sering melakukan hal-hal yang aneh seperti menelepon kamu 100 kali dalam sehari. Atau mengejutkan kamu di tengah malam dengan mengirim SMS. Sebenarnya ketika itu dia sedang memikirkan kamu.

17. Orang yang mencintai kamu kadang-kadang merindukan kamu dan melakukan hal-hal yang membuat kamu sakit kepala. Namun ketika kamu mengatakan tindakannya itu membuat kamu terganggu, dia akan meminta maaf dan tidak akan melakukannya lagi.

18. Jika kamu memintanya untuk mengajarimu sesuatu maka ia akan mengajarimu dengan sabar walaupun kamu mungkin orang yang terbodoh di dunia. Bahkan dia begitu gembira karena dapat membantu kamu. Dia tidak pernah mengelak dari melaksanaan permintaanmu walaupun sesulit apappun.

19. Kalau kamu melihat HP-nya maka nama kamu akan menghiasi sebagian besar INBOX-nya. Dia masih menyimpan SMS-SMS dari kamu walaupun kamu mengirim berbulan-bulan atau bertahun-tahun yang lalu. Dia juga menyimpan surat-surat kamu di tempat khusus dan segala pemberian kamu menjadi benda-benda berharga buatnya.

20. Dan jika kamu coba menjauhkan darinya atau memberi reaksi menolaknya, dia akan menyadarinya dan menghilang dari kehidupan kamu, walaupun hal itu membunuh hatinya.

21. Jika suatu saat kamu merindukannya dan ingin memberinya kesempatan, dia akan ada menunggu kamu karena sebenarnya dia tak pernah mencari orang lain. Dia sentiasa menunggu kamu.

22. Orang yang begitu mencintaimu, tidak pernah memaksa kamu memberinya sebab dan alasan, walaupun hatinya meronta ingin mengetahui, karena dia tidak mau kamu terbeban dengan karenanya. Saat kau pinta dia berlalu, dia pergi tanpa menyalahkan kamu, karena dia benar-benar mengerti apa itu CINTA.

Ketika tiba saat perpisahan janganlah kalian berduka, sebab apa yang paling kalian kasihi darinya mungkin akan nampak lebih nyata dari kejauhan - seperti gunung yang nampak lebih agung terlihat dari padang dan dataran.

Ketika aku berdiri bagaikan sebuah cermin jernih di hadapanmu, kamu memandang ke dalam diriku dan melihat bayanganmu. Kemudian kamu berkata, ‘Aku cinta kamu’. Tetapi sebenarnya, kamu mencintai dirimu dalam diriku.

Kamu mungkin akan melupakan orang yang tertawa denganmu, tetapi tidak mungkin melupakan orang yang pernah menangis denganmu.

Waktu kamu lahir, kamu menangis dan orang-orang di sekelilingmu tersenyum. Jalanilah hidupmu dan berbuatlah baik sehingga pada waktu kamu meninggal, kamu tersenyum dan orang-orang di sekelilingmu menangis.

Butuh satu menit untuk tertarik kepada seseorang, satu jam untuk menyukai seseorang, satu hari untuk mencintai seseorang tetapi membutuhkan waktu seumur hidup untuk melupakan seseorang yang dicintai.

Hal yang menyedihkan dalam hidup adalah ketika bertemu seseorang yang sangat berarti bagi kita, namun akhirnya kita terpaksa membiarkan dia pergi. Ketika pintu kebahagiaan tertutup, yang lain terbuka. Tetapi kadang kala kita menatap terlalu lama kepada pintu yang tertutup itu sehingga kita tidak melihat pintu yang lain terbuka untuk kita.

1. Sayangi dia dengan hati, bukan dengan perasaan. Jika anda menyayangi dia berdasarkan perasaan, maka akan gagal karena perasaan sentiasa berubah dari masa ke masa.

2. Sayangi dia seadanya. Di dunia ini terdapat hampir 6 milyar manusia dengan 6 milyar kepribadian yang berbeda. Dia memang seseorang yang istimewa dan biarkan dia seperti begitu. Jangan sekali-kali berpikir untuk mengubah sesuatu tentang dirinya karena sekali anda mengubah, selamanya anda akan terus mengubah dirinya. Tentu anda masih ingat, anda terpikat padanya karena dia adalah dia. Maka, tidak ada alasan bagi anda mengubah dia untuk menjadi seseorang yang lain.

3. Sayangi dia sepenuh hati. Sesungguhnya dia telah banyak berkorban untuk anda. Dengan kelebihan yang ada padanya, dia berpeluang untuk menjalin hubungan dengan orang lain yang lebih sempurna dari anda. Tapi demi cintanya kepada anda, dia tetap memilih anda. Maka, jangan sekali-kali mencoba untuk mempermainkan keluhuran cintanya.

4. Hormati pendirian dan keputusan dia. Jangan anda merayu dan jangan membuat alasan supaya dia menerima cinta anda karena kelak, yang anda akan dapat darinya hanyalah cinta simpati dan bukan cinta setulus hati.

5. Yakinkan diri anda akan keistimewaan dia. Dia adalah satu-satunya di dunia ini dan jangan mengharapkan kesempurnaan dari dia karena dia telah cukup sempurna semenjak anda mulai terpikat kepadanya.

6. Percaya akan dirinya. Sentiasa berbaik sangka padanya jika kita mau dia juga begitu. Pastikan sentiasa meletakkan diri anda di tempatnya sebelum melakukan apa-apa. Jika anda sendiri tidak dapat menerimanya, apalagi dia.

7. Jangan berjanji menyayangi dia untuk selama-lamanya karena selama-lamanya bagi anda mungkin akan berakhir keesokkan harinya, tapi berjanjilah untuk menyayangi dirinya seolah-olah setiap hari itu adalah hari yang terakhir untuk anda berdua.

8. Bercinta dengannya adalah seperti memberi hati anda kepadanya untuk dilukai tapi kepercayaan itu penting. Percayalah kepadanya, niscaya dia akan melindunginya sepenuh jiwa dan raga.

9. Jangan sesekali meninggalkan dia tanpa alasan. Dia bukan hanya akan menangis kecewa dan kemudian meneruskan hidup seperti biasa, ketahuilah bahwa jiwanya akan mati secara perlahan.

10. Jangan cepat berbangga dengan diri anda, memenangi hatinya bukanlah satu kejayaan yang mutlak tetapi anugerah. Itu hanya layak anda peroleh setelah anda berjaya menyayanginya hingga akhir hayat. Ketahuilah, dia memilih anda karena dia percaya bahwa anda adalah seseorang yang jujur dan akan menepati janji. Anda telah bersusah payah dan berusaha segala upaya untuk memenangi cintanya, maka dengan itu haruslah juga anda berusaha untuk terus mencintai dirinya dalam keadaaan apapun.

Cinta dapat mengubah pahit menjadi manis, debu beralih emas, keruh menjadi bening, sakit menjadi sembuh, penjara menjadi telaga, derita menjadi nikmat, dan kemarahan menjadi rahmat.

Sungguh menyakitkan mencintai seseorang yang tidak mencintaimu, tetapi lebih menyakitkan adalah mencintai seseorang dan kamu tidak pernah memiliki keberanian untuk menyatakan cintamu kepadanya.

Sekiranya kamu mendapati dirimu mencintai seseorang yang tidak membalas cintamu, janganlah merasa tersisih. Tidak ada salahnya mencintai seseorang karena cinta tidak memilih untuk singgah di hati seseorang.

Sekiranya kamu dicintai oleh seseorang yang tidak kamu cintai, anggaplah suatu penghormatan bagimu tetapi kembalikan penghormatan itu dengan cara yang ikhlas dan jujur. Jangan ambil kesempatan dan janganlah melukai.

Bagaimana kamu mengurusi cinta begitulah kamu mengurusi dirimu dan setiap hati dan perasaan mengalami kepedihan dan kebahagiaan yang serupa sekalipun cara kita mengendalikannya berbeda.

Sekiranya kita mencintai seseorang yang begitu mencintai diri kita dan tiba-tiba cinta itu memilih untuk pergi, tidak ada yang disalahkan, relakanlah cinta itu pergi. Karena setiap sesuatu ada hikmahnya yang tersembunyi.. Dan kita akan menyadarinya seiring berjalannya waktu.

Ingatlah bahwa jangan terlalu memilih cinta. Karena cinta itu sendiri yang akan memilih untuk singgah di hati seseorang, Kamu hanya perlu menerima kehadiran cinta itu dengan segala misteri di dalamnya, apabila ia datang mengetuk pintu hatimu.

Nikmati cinta sebagaimana ia membuat hidupmu bahagia dan bebaskan ia. Cinta sentiasa dan akan selamanya menjadi misteri. Bersyukurlah karena dia pernah singgah di hatimu…

Tidak semua orang yang engkau cintai, mencintaimu dan sikap ramahmu kadang kala dibalas dengan sikap tidak sopan. Jika cinta suci tidak datang dari perilakunya, maka tidak ada gunanya cinta yang dibuat-buat.

Sayang tidak bermaksud cinta. Suka tidak serasi dengan cinta. Kagum tidak berarti cinta. Bangga tidak semestinya cinta. Cinta adalah CINTA.

Cinta itu seperti sinar matahari, memberi TANPA mengharap kembali. Cinta itu seperti sinar matahari, TIDAK MEMILIH siapa yang ia sinari. Cinta itu seperti sinar matahari yang MEMBERI KEHANGATAN DI HATI.

Don’t find love, let love find you. That’s why it’s callled falling in live, because you don’t force yourself to fall, you just fall.

Lucky is the man who is the first love of a woman, but luckier is the woman is the last love of a man.

It breaks your heart to see the one you love is happy with someone else, but it’s more painful to know that the one you love is unhappy with you.

Love me now, love me never, but if you love me, love me forever.

To the world you may be just one person, but to one person you may be the world.

Love is to love someone for who they are, who they were, and who they will be.

Daftar Blog Saya

Entri Populer